DY Experience OS Pages Loading Slowly At Times For US Sections

Incident Report for Dynamic Yield

Resolved

This incident has been resolved and the DY admin page load has returned to normal.
Posted Mar 19, 2025 - 23:11 IST

Monitoring

Page loading delays in the DY admin are improving and we're continuing to monitor to ensure all performance returns to normal.
Posted Mar 19, 2025 - 22:07 IST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 19, 2025 - 20:10 IST

Investigating

We are currently investigating reports of some DY admin pages loading slowly for some users.
Posted Mar 19, 2025 - 18:52 IST
This incident affected: Administration Site.