DY Admin Page Loading Issues For US and EU Sections

Incident Report for Dynamic Yield

Resolved

A fix has been implemented and pages in the DY admin should now be loading successfully.

We apologize for any inconvenience this has caused!
Posted Jun 24, 2025 - 19:09 IDT

Identified

We have identified an issue that is affecting the loading of some pages of the Dynamic Yield admin and we are currently implementing a fix.
Posted Jun 24, 2025 - 18:34 IDT
This incident affected: Administration Site.