EU & US Sections | Custom Filter Rules Not Applying in Recommendations for Some Newly Created Strategies

Incident Report for Mastercard Dynamic Yield

Resolved

This incident has been resolved.
Posted May 20, 2026 - 13:11 UTC

Monitoring

A fix has been implemented, and we are actively monitoring results. Rules in the affected recommendation strategies are now being applied correctly.

We will continue to monitor to ensure sustained performance.
Posted May 19, 2026 - 19:17 UTC

Investigating

Our engineering team is actively investigating to identify the root cause and implement a fix. This issue appears limited to strategies created with custom filter rules on May 19, 2026.

Existing strategies created before May 19, 2026 continue to apply the rules as expected.
Posted May 19, 2026 - 15:28 UTC
This incident affected: Recommendation API.