Issues on the USE server with real time affinity and API feeds.

Incident Report for Mastercard Dynamic Yield

Resolved

All services are back to normal and operational.
Posted May 08, 2026 - 13:28 UTC

Update

Issue resolved.
Posted May 08, 2026 - 12:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 08, 2026 - 12:32 UTC

Update

Services are starting to recover, some delays still in API feed.
Posted May 08, 2026 - 11:52 UTC

Identified

Issue is due to AWS global outages. We are pushing for ETA.
Posted May 08, 2026 - 06:42 UTC

Investigating

We are facing issue with the real time affinity (affinity campaigns), the delta api requests will fail (api feed updates), there will be delay in reports

Who does this effect? US server.

When did this issue start?
08/05/2026
Start - 3:30 AM UTC+2

Currently, we do not have an ETA, but will continue to update as we progress.

Our apologies for the inconvenience this may have caused.
Posted May 08, 2026 - 06:08 UTC
This incident affected: Collection Layer, Serving Layer - U.S. east, Data Feeds, and Reporting.